Sharing Ilmu

Sharing for useful things

How To Remove or Change configuration on Router/Switch Cisco Packet Tracer

In this tutorial I’ll discuss about how to remove or change configuration on cisco router/switch. when we have configured on router/switch but it’s wrong configuration or need to remove the configuration how to do that ?  and when we need to change configuration how to do that ?

When we need to remove configuration on router/switch cisco we just only need to reconfigure it with added no in front of script.

Let say you already configured on router. check running configuration on your router.

MyRouter#show running-config
Building configuration...
Current configuration : 830 bytes
!
version 16.6.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MyRouter
!
enable secret 5 $1$mERr$3HhIgMGBA/9qNmgzccuxv0
enable password 12345
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface Loopback1
ip address 192.168.100.1 255.255.255.0
!
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
banner motd ^CThis Is Router Core^C
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
MyRouter#

 

For example if you need to remove enable password and ip address on Loopback1 :

MyRouter(config)#no enable password

Show running config again :

MyRouter#show run
Building configuration...
Current configuration : 808 bytes
!
version 16.6.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MyRouter
!
enable secret 5 $1$mERr$3HhIgMGBA/9qNmgzccuxv0
!
!

Enable password already removed.

Remove ip address from Loopback1 :

MyRouter(config)#int lo1
MyRouter(config-if)#no ip add 192.168.100.1 255.255.255.0
MyRouter(config-if)#exit

Show Running config again :

MyRouter#show run
Building configuration...
Current configuration : 783 bytes
!
version 16.6.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MyRouter
!
enable secret 5 $1$mERr$3HhIgMGBA/9qNmgzccuxv0
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface Loopback1
no ip address
!
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!

 

IP Address from interface loopback1 already removed.

 

Now How to change the configuration ? for example we need to change ip address configuration on Interface Gigabit0/0/0 from 192.168.1.1 255.255.255.0 to 192.168.100.1 255.255.255.0 

For change the configuration, just configure again in that interface.

MyRouter(config)#int g0/0/0
MyRouter(config-if)#ip add 192.168.100.1 255.255.255.0
MyRouter(config-if)#exit

Show Running-config on router :

MyRouter#show running-config
Building configuration...
Current configuration : 785 bytes
!
version 16.6.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MyRouter
!
enable secret 5 $1$mERr$3HhIgMGBA/9qNmgzccuxv0
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface Loopback1
no ip address
!
interface GigabitEthernet0/0/0
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
no ip address
duplex auto

IP Address on Gigabit0/0/0 already change.

 

z

Leave a Reply

Your email address will not be published. Required fields are marked *.

*
*
You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>